Software differences between Classic Linux hosting and cPanel

If you are moving from Classic hosting to cPanel, you will be using new versions of several programming and database languages. If your site uses old code that is no longer supported, it can cause your site to display error messages or stop working altogether.

Language/Software Classic Web Hosting cPanel Hosting
PHP 5.2, 5.3, 5.4 5.3, 5.4, 5.5, 7.0, 7.1 (default)
Ruby 1.8.4 1.8.7
Python 2.4.3 2.6.6
Apache 2.2 2.4
Perl 5.8.8 5.10.1
MySQL 5.0 5.5

Note: If your site is custom-built and uses functions that are deprecated in PHP 5.2, you may need to make updates to the code to avoid warnings or errors on your site.

The latest version of most web applications (WordPress, Joomla, Drupal, etc.) are already compatible with cPanel shared hosting. Make sure your applications are up to date before moving.

Next steps

As long as your site will not have any problems with the listed version changes, you can continue moving your site to cPanel.


Var den här artikeln till hjälp?
Tack för din feedback. Ring vårt supportnummer eller starta chattalternativet ovan om du vill prata med en medarbetare på kundtjänst.
Vi är glada att vi kunde hjälpa till! Finns det något mer vi kan göra för dig?
Det var tråkigt att höra. Berätta vad som var krångligt eller varför lösningen inte hjälpte dig med problemet.